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I. Introduction
I-1. Purpose
This document provides specific technical information for users of the CLEA software module Radio Astronomy of
Pulsars. It includes discussions of hardware and operating system requirements (Section II); software installation and
operation (Section III); files associated with the exercise (Section IV); user options and file formats for possible user
modifications (Section V); and astronomical data, models and algorithms employed in the exercise (Section VI). The
material in this guide is intended for use by the instructor and by other personnel involved in installing and configuring
the exercise software and PC hardware. It is not intended for distribution to the students. (The word “user” when it
appears herein should be interpreted as “instructor”, and not “student”.)
Readers of this document are assumed to have available the General Users’ Guide to CLEA Windows Software, which
contains technical information that applies to all CLEA Windows software. Much information contained therein is not
repeated here. In cases of conflicting information, this guide should be considered definitive for the Radio Astronomy of
Pulsars software. In particular, please note that this software is distributed in a different form than previous CLEA modules
(see Section III for details).
I-2. Acknowledgments
Development of CLEA exercises and materials, including this guide, is supported in part by National Science Foundation
Grants USE 9155927, USE 9354514 and DUE 9652801, and by Gettysburg College.

II. System Requirements
This software runs under Microsoft Windows, and is distributed in two versions: a 16-bit application for Windows 3.1/3.11,
and a 32-bit application for Windows 95/NT. Details concerning the available distribution formats are given in Section III.
A minimum of 8 Mbytes of RAM (16 Mbytes for Windows 95/NT) is recommended, although smaller configurations (down
to 4 MB for Win3.1/3.11 and 8 MB for Win95/NT) may prove sufficient. A color SVGA video controller and monitor is
required. A full installation will require about 3 Mbytes of hard disk storage. A Sound Blaster compatible (8- or 16-bit)
sound card and speakers are required for the sound features, which are available only in the 32-bit version.
Users may find that PCs employing 386 processors, while usable, are not fully adequate for this software. In particular,
considerable delays may be experienced at certain points, such as when the Mode button on the receiver is pressed to begin
receiving a signal. A 486 processor is generally satisfactory, with the exception that there may be some difficulty keeping
the sound synchronized with the visual display (see Section VI-2). No problems (that we are aware of) have been experienced
with Pentium processors.

III. Installation and Operation
Unlike previous CLEA programs (which are distributed as .ZIP files), this software is distributed as a self-extracting executable
module that includes an installation program. Three distribution formats are available, as listed in Table III-1. Module
INST_PLS.EXE contains both the 16-bit (for Windows 3.1/3.11) and 32-bit (for Windows 95/NT) versions of the executable
code, as well as installation logic to determine and install the correct version without user interaction. However, this module
is too large to distribute on a single 1.44 Mbyte floppy, and is therefore available only for download from the CLEA ftp site
(io.cc.gettysburg.edu). (You can also access this site through the World Wide Web. Begin with the Project CLEA home
page at www.gettysburg.edu/project/physics/clea/CLEAhome.html ) For floppy disk distribution, the two versions are
separated. Module IN31_PLS.EXE installs only the 16-bit version, while IN95_PLS.EXE installs only the 32-bit version.
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Table III-1 Software Distribution Modules
Module

Description

INST_PLS.EXE

Contains both 32-bit and 16-bit versions of the exercise software. Determines
and installs the correct version for the current operating system. This module
is distributed via ftp download.

IN31_PLS.EXE

Contains and installs the 16-bit version, for Windows 3.1/3.11 (see Note below).
This module is distributed on floppy disk.

IN95_PLS.EXE

Contains and installs the 32-bit version, for Windows 95/NT. This module
will not execute under Windows 3.1/3.11. This module is distributed on floppy
disk.

Note: The installation program IN31_PLS.EXE, as well as the 16-bit version of the
exercise software, will operate under Windows 95/NT, but we recommend that the 32bit version be used, especially since the 16-bit version does not contain the sound features.
To install the exercise software from a floppy disk
1.

Place the distribution diskette in a floppy drive. (This will be either drive a or drive b.)

2.

Using the File Manager or Windows Explorer, access the floppy drive (A: or B:) and verify that you have the
correct installation module for your operating system (IN31_PLS.EXE for Windows 3.1/3.11, IN95_PLS.EXE
for Windows 95/NT).

3.

If the version is correct, double-click on the program entry (IN31_PLS.EXE or IN95_PLS.EXE) in the File
Manger/Windows Explorer display.

To install the exercise from a downloaded module
1.

Using the File Manager or Windows Explorer, locate the module INST_PLS.EXE. (You will have placed this
module in some directory/folder, such as C:\SAVSTUFF\CLEA, when you downloaded it. If you are running
Windows 95, you can select Tools->Find->Files or Folders... from the Windows Explorer menu to help you
locate INST_PLS.EXE.)

2.

Double-click on the program entry for INST_PLS.EXE in the display.
Note: Experienced Windows users will realize that there are means other than those described above to
initiate the install program. A quick method, if you are certain of the path and file names, is to select Start>Run (Windows 95), or File->Run from the Program Manager menu (Windows 3.x). In the dialog box, enter
the path and program name (such as “A:\IN31_PLS.EXE” or “C:\SAVSTUFF\CLEA\INST_PLS.EXE”), and
click on OK. Use whatever method you prefer.

After the installation program starts it will ask you to select a folder (directory) in which to place the software, and a program
group for the icon. (If you have already created a program group for other CLEA software you will probably want to place
this exercise there also.) Except for these selections, the installation process is completely automatic, and quite fast. When
it is finished, an icon for the exercise should appear in the selected program group and on the start menu (Windows 95).
During installation, program INST_PLS.EXE will determine the version of Windows that is present and install the correct
CLEA software module. There are some differences in appearance and functionality between the 16-bit and 32-bit versions.
In particular, if you are running Windows 3.1 or 3.11, the 16-bit module will be installed and the sound features will not be
available, regardless of whether or not you have a sound card and speakers.
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If you upgrade to Windows 95 after installing this software, you will retain the 16-bit version, but switching to the 32-bit
version is not difficult. If you have only IN31_PLS.EXE you will need to obtain either INST_PLS.EXE or IN95_PLS.EXE,
if you already have INST_PLS.EXE you are ready to go. Simply re-run the installation as described above, selecting the
same destination folder and program group as before, and the 32-bit software will be installed. If you want to conserve disk
space, you can then use the Explorer or File Manager to delete CL16_PLS.EXE from the folder (do not delete anything
else).
III-1. Network Installation
Installation of CLEA software on networks is described in detail in the General Users’ Guide to CLEA Windows Software.
Because this exercise is not distributed as a .ZIP file, you must run the installation program as described above to unpack the
files. For a network installation, identify the appropriate shared drive when specifying the folder to hold the software.
(Obviously, you must have write privileges on the network drive when you do this.) Another technique is to install the
software on any PC, and then copy the entire contents of the program folder to the network drive. Once you have done this,
you must create a local directory and install the exercise on all machines that will use it. This process is described in Section
III of the General Users’ Guide to CLEA Windows Software, with specific instructions for Windows 3.n and Windows
95.

IV. Files Included With This Exercise
IV-1. Files Created During Installation
The following files are compressed into the distribution file (INST_PLS.EXE, IN95_PLS.EXE, or IN31_PLS.EXE). Files
not contained in all distribution versions are noted. The compressed files are extracted and placed in the exercise folder
(directory) during installation. The list is grouped by function, with references to related discussions in this document and
the General Users’ Guide to CLEA Windows Software.
Software and Documentation
README.PLS -

Notes on the current version, if any.

UPDATE.PLS -

A list of updates (by version) since version 0.70 (the first version to be widely
circulated).

USRGUIDE.PLS -

This document, in text form.

CL32_PLS.EXE -

32-bit executable code for the exercise. (Distributed in INST_PLS.EXE and
IN95_PLS.EXE.)

CL16_PLS.EXE -

16-bit executable code for the exercise. (Distributed in INST_PLS.EXE and
IN31_PLS.EXE.)

Bitmap Files for Displays
CLEALOGO.BMP -

256-color bitmap data for the CLEA logo screen.

PULSRLAB.BMP -

256-color bitmap data for the Title screen.

ARECIBO.BMP -

256-color bitmap image of the Arecibo telescope.

NRAOGBTV.BMP -

256-color bitmap image of the Greenbank (GBT) telescope.
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Bitmap Files for Displays Con’t
CLEALG16.BMP
PULSRL16.BMP
ARECIB16.BMP
NRAOGB16.BMP -

16-color versions of the above bitmaps.

DIGIT_O.BMP
DIGIT_1.BMP
DIGIT_2.BMP
DIGIT_3.BMP
DIGIT_4.BMP
DIGIT_5.BMP
DIGIT_6.BMP
DIGIT_7.BMP
DIGIT_8.BMP
DIGIT_9.BMP
PERIOD.BMP
MINUS.BMP
COLON.BMP
BLANK.BMP -

Characters for the simulated LED displays.

CLEA32.ICO -

Icon for the Radio Astronomy of Pulsars exercise.

RADTEL.ICO -

Icon for the receiver windows.

Pulsar Data (Section V-2)
PULSARS.DAT -

Data for 558 pulsars.

PULSARS.TXT -

Description of data in PULSARS.DAT.

HOTPLSRS.LST -

A finding list of “interesting” pulsars. (This list may be modified during program
execution - see discussions of parameters Write Hot List File and Exact Pos for
Hot List in Section V-1.1 .)

Help and Related Files (Section V-3 in General Users’ Guide to CLEA Windows Software)
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CLEAHELP.HLP -

Text for Help->On Help.

PULSRHLP.LST -

Topic Index List for Help on using radio telescope and receivers.

PULSRLAB.HLP -

Text for Help topics on using radio telescope and receivers,

PLSANHLP.LST -

Topic Index List for Help on Data Analysis features.

PULSRANL.HLP -

Text for Help topics on Data Analysis features.

PLSLSHLP.LST -

Topic Index List for Help on Pulsar List features.

PULSRLST.HLP -

Text for Help topics on Pulsar List features.

REMINDER.PLS -

Text to display when Exit selected.

Version 1.0

IV-2. Files Generated During Execution
The following files are generated during execution of this exercise. Files CLEALOG.LOG and PLSROPTS.INI are
automatically created, files with extensions .PLR and .CSV are created on option, as noted. For a discussion of the placement
of these files (path and folder/directory), see Section III-3.3 in the General Users’ Guide to CLEA Windows Software.
CLEALOG.LOG - A record that includes the program name (“CLEA_PLS”), the date and time, and the names
and table number from the Login dialog is appended to this file whenever the exercise is started, and when
it is terminated. This file is in text format and can be read and/or printed at any time. Since this file can
grow without limit it should be deleted from time to time (via DOS or the Windows Explorer/File Manager).
A new file will then be started at the next login. This file can optionally be given a different name (see
Section V-1.3).
Note: A logout record will be written to this file only if the students exit correctly from the program
(select File->Exit from the main menu, or close the main window from the System Menu or “X” box).
They should be instructed to do this, rather than simply abandoning the computer or turning it off.
PLSROPTS.INI - Current settings for file names and options. This file can be deleted if desired, it will then be recreated from internal defaults when the program is run. If the options are updated (see Section V-1), the
previous version is saved as PLSROPTS.BAK.
*.PLR - Files with the extension .PLR are written when recorded radio signals from pulsars are saved for later
analysis. Names for these files are generated from the first login name (“Student #1”), as described below
(Section IV-2.1). The format of these files is described in Section V-2.3.
*.CSV - A file with extension .CSV is written when Results->Save Recorded Measurements is selected from the
Data Analysis menu. (The file name is generated from the first login name - see Section IV-2.1 below.)
This file is written in a format (Comma Separated Values) that can be used as input to most commercial
spreadsheet programs. See Section V-3 for information about using a spreadsheet program with this
exercise, and the contents of the .CSV file.
Note: Files *.PLR and *.CSV should be periodically deleted from the working directory when they are
no longer needed. This can be done under DOS or via the Windows Explorer/File Manager.
IV-2.1. Naming .PLR and .CSV Files
Names for the student-generated .PLR and .CSV files are created from the first login name (“Student #1”). If the login entry
includes both a first and last name, the first letter of the name is combined with the first seven (if present) letters of the last
name. If only one name is entered, the first eight (if present) letters are used. For subsequent files, the name is truncated (if
necessary) to five characters. A three character running number is then added, along with the extension.
Examples:

Login Name

File Names

Annie Jump Cannon

ACANNON.CSV
ACANN001.PLR

Martin Schwarzschild

MSCHWARZ.CSV
MSCHW012.PLR

Galileo

GALILEO.CSV
GALIL005.PLR

If the first login name is blank, the files are named NOLOG(xxx).CSV/PLR.
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V. User Options and Data
This software has been designed to provide the user with a great deal of flexibility in configuring the facility for specific
needs. Users may adjust simulation parameters, specify telescope type, select from a list of optional features, change the
station location, specify alternate bitmaps for display, modify the Help facility, attach a spreadsheet program, and modify the
underlying pulsar data. Details of the facilities providing this adaptability are given in Sections V-1 through V-3 below.
V-1. Parameters and Selectable Options
In all CLEA software, modification of control parameters and options is accomplished through an options dialog that is
accessed from the login dialog, via a password. Details of this feature, including the password access, are provided in the
General Users’ Guide to CLEA Windows Software. Due to the number of modifiable features associated with this
exercise, the options facility comprises three dialog windows, as detailed in the Sections that follow (V-1.1 through V-1.3).
V-1.1. Simulation Options and Parameters
The following switches and parameters appear on the window titled Simulation Options, which appears as the main dialog
when the options facility is accessed.
Horizon Limit: The limiting height above the local horizon (in degrees) for telescope slewing (see Limit Slewing).
The default is 10.0.
Antenna Aperture: The aperture of the simulated radio telescope, in meters. The default is 100.
Base Slew Rate: The base slew increment in arc seconds applied at each slew timer message. This value is
multiplied by the slew rate factor set from the control panel. The default is 50.
Base Gain Factor: This factor can be used to adjust the overall receiver gain. The default is 1.00.
Background Base: This factor sets the overall background level. The received background is adjusted for
background temperature in the field (if known), detector temperature, and receiver frequency (see Section
VI-1.2). The default is 5.
Beam Width: The effective telescope beam width in degrees. If this value is zero, the half-power beam width
(HPBW) is calculated from the telescope aperture and receiver frequency, and an attenuation factor is
applied if the pulsar is not at the center of the beam (see Section VI-1.3). Setting this parameter to a nonzero value makes it easier for students to locate objects using coarse telescope pointing. The default is 0
(zero).
Detector Temperature: The effective temperature (K) of the detector system. This establishes the level of noise
contributed by the detector (see Section VI-1.2). The default is 50K.
Sound Sync Factor: This parameter is used to adjust the synchronization between the video display and the
sound. Please read Section VI-2.3.2 before modifying this value. The default is 0.92000.
Sound Sample Rate: The sampling rate for the generated sound. Increasing this value raises memory (RAM)
usage by increasing the size of the sound buffers (see Section VI-2). The default rate is 5512 Hz.
Telescope Type: This software will simulate three types of telescope: fully steerable, which can be pointed to any
spot in the sky above the local horizon; meridian transit, which can be slewed only in declination; and
Arecibo type, which can be pointed only within a few degrees of the local zenith. The default is fully
steerable. (Also see Horizon Limit and Limit Slewing.)
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Pulsar Identification: This option instructs the software to identify the current pulsar by its J2000 positional
designation, its B1950 designation, or not to identify the pulsar. (The pulsar identification appears on the
receiver window when there is a pulsar in the beam, and on recorded data.) The default is the B1950
designation, which is the most commonly used.
Demonstration Mode: This option is provided for those who may wish to avoid the login process when using this
software as a demonstration. When this switch is on, the Run selection as well as Login (both under File
on the main menu), are enabled when the program starts. If Run is then selected before Login, the
program proceeds as if the login process had actually occurred. (In this case the 1st login name is set to
Demonstration, the file name base becomes DEMO, and the Login menu selection is disabled.) The
default is Off. (Also see Test Mode and Access Pulsar List.)
Limit Slewing: If this switch is set, the telescope cannot be slewed below the local horizon limit. Turning this
option on makes the exercise somewhat more complicated, since the students must concern themselves
with observation time, local sidereal time, etc. The default is Off.
Fast Slewing: This option activates the fastest slewing rate, which is unrealistic for large radio telescopes. Leaving
this option on may help alleviate student complaints about having to wait so long, especially if a number
of observations are being made. The default is On.
Plot Pulsar Positions: If this option is set, the positions of all the pulsars in the pulsar data file (see Section V-2.1)
will appear on the sky map displayed in the telescope control window. The default is Off.
Write Hot List File: This option allows the students to make permanent changes to the Hot List file. If the option
is off, the students can modify the hot list as they wish during the exercise, but cannot save their changes
to the file. The default is Off.
Exact Pos for Hot List: This option assures that entries made to the hot list will carry the exact pulsar positions
from the pulsar data file, rather than the current telescope pointing coordinates. This guarantees that
pulsars accessed from the hot list will always be in the telescope field, regardless of the Beam Width
setting. The default is Off.
Sound Features: This option activates the sound features, provided that the software detects a viable sound card.
The sound features are not available in the 16-bit version of the software (see Sections II and III) . For the
32-bit software, the default is On.
Test Mode: In test mode, slewing to specified coordinates and hot list positions is instantaneous, and the Preferences
menu selection for user options is always enabled. Instructors may find this mode useful for demonstrations
and in creating/verifying exercises. The default is Off. (Also see Demonstration Mode and Access
Pulsar List.)
Access Pulsar List: When this option is set, the user has access to the pulsar list data (see Section V-2.1) via a
selection on the main menu (File->Pulsar List...). (The selection doe not appear until the telescope
control window has been activated.) The Pulsar Parameters window displays all quantities used by the
program (see Table V-1), and includes facilities for searching for pulsars by name and calculating values
of the period as a function of the date, and distance as determined from the electron density. This feature
is intended to assist instructors in developing observation lists for exercises and verifying student results,
and may also be useful for demonstrations. The default is Off.
Lab Table Number: This field allows the instructor to preset the table number for each machine in the lab. This
number then appears as the default on the Login dialog. The table number has a maximum length of 4
characters, but need not be numeric.
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Password: This is the password for access to the Options dialog. Allowable passwords have a maximum length of
16 characters, and are case sensitive. The default password is “CLEA”.
V-1.2. Time and Location Parameters
The following station location and local time parameters appear on the window titled Time & Location Parameters. To
access this dialog press the button labeled Station... on the Startup Parameters/Options window.
Location: Name/description of the observatory or radio telescope (79 characters max.). The default is “Gettysburg
College Radio Observatory”.
Longitude: Longitude of the radio telescope. The default is 79deg, 13min, 56sec West.
Latitude: Latitude of the radio telescope. The default is 39deg, 49min, 52sec North.
Local Time Difference: UT minus local (zone) time in hours for the observatory. The default is 5 hours (Eastern
Standard Time).
Altitude: Altitude of the observatory or station in meters. The default is 176.8 meters.
V-1.3 File Name Options
The following file and path name parameters appear on the window titled File Name Options. To access this dialog press
the button labeled Files... on the Startup Parameters/Options window. See the General Users’ Guide to CLEA Windows
Software for discussions of Windows bitmap (.BMP) files, including logo and title screens and color issues.
256-Color Logo: A 256-color bitmap for the CLEA logo screen. The default is “CLEALOGO.BMP”.
16-Color Logo: A 16-color bitmap for the CLEA logo screen. The default is “CLEALG16.BMP”.
256-Color Title: A 256-color bitmap for the exercise title screen. The default is “PULSRLAB.BMP”.
16-Color Title: A 16-color bitmap for the exercise title screen. The default is “PULSRL16.BMP”.
256-Color View: A 256-color bitmap for the control panel view screen. The default is “NRAOGBTV.BMP”.
16-Color View: A 16-color bitmap for the control panel view screen. The default is “NRAOGB16.BMP”.
Pulsar Data: The pulsar data file (see Section V-2.1). The default is “PULSARS.DAT”.
“Hot” List: The hot list file (see Section V-2.2). The default is “HOTPLSRS.LST”.
Main Help List: An index list of Help topics (see General Users’ Guide to CLEA Windows Software) for
the main window (telescope controls and receivers). The default is “PULSRHLP.LST”.
Analysis Help List: An index list of Help topics for the Data Analysis window. The default is “PLSANHLP.LST”.
Pulsar List Help List: An index list of Help topics for the Pulsar Parameters window (see Access Pulsar List in
Section V-1.1). The default is “PLSLSHLP.LST”.
User Help File: Site-specific Help information available under Help->User (see General Users’ Guide to CLEA
Windows Software). The default is “” (no entry).
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Reminder File: Text to be displayed when the students want to terminate the exercise (see General Users’ Guide
to CLEA Windows Software). The default is “REMINDER.PLS”.
Spreadsheet Program File: The full name (including path) of a spreadsheet program to be accessed during the
exercise for data manipulation and analysis (see Section V-3 for details). The file must be of type .EXE
or .PIF, and must be accessible from the student’s computer in the drive and file specified (example:
C:\MSOFFICE\EXCEL\EXCEL.EXE). This parameter is completely optional. There is no default.
Log File: A file (text) where log information is written during login and at termination of the exercise (see Section
IV-2). This file name can optionally include a full path, presumably to a single shared log file (which of
course must be write-enabled). The default is “CLEALOG.LOG”, with no path designation.
V-2. Data Files
Data files created and/or used by this software are described in this section. These files are in text format for ease of
maintenance and modification (as is the case with virtually all CLEA data files).
V-2.1 Pulsar Data File
The Pulsar Data File includes the full Catalog of 558 Pulsars (Taylor et al, 1993), available on CD-ROM in Selected
Astronomical Catalogs, Volume 2. A full description of this data is given in the file PULSARS.TXT, included with this
exercise. (The file PULSARS.DAT is identified therein as table1.dat.) The specific data fields used are listed in Table V1. We have made one minor modification to this data: the “D” exponent notation (FORTRAN double-precision floating
point), where it occurs, has been changed to “E” for compatibility with Pascal I/O. The generation of the observed pulses
and periods from the pulsar data is described in Section VI-1. (Also see Access Pulsar List in Section V-1.1.)
Table V-1. Pulsar Data Used
Name

Description

Jname

The J2000 Pulsar Name

Bname

The B1950 Pulsar Name

RA2000

The J2000 Right Ascension in Decimal Degrees

DEC2000

The J2000 Declination in Decimal Degrees

P

The Barycentric Period in Seconds

Pdot

The Barycentric Period Derivative in Sec/Sec

PEpoch

Epoch of the Barycentric Period (MJD)

TBg

Sky Background Temperature in K

DM

Dispersion Measure in pc/cm3

w50

Profile Width at 50% of Peak in ms

s400

Time Averaged Flux Density at 400MHz in mJy

s600

Time Averaged Flux Density at 600MHz in mJy

s1400

Time Averaged Flux Density at 1400MHz in mJy
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V-2.2 Pulsar Hot List File
The Pulsar Hot List File is a finding list of names and positions of pulsars selected for study, along with pertinent comments.
Although the Hot List File may be modified off-line with a text editor, items are normally added to or deleted from this list
through the exercise software (see discussions of parameters Write Hot List File and Exact Pos for Hot List in Section V1.1, and the “Hot” List file name parameter in Section V-1.3). The format of the file records is given in Table V-2, data
items in each record must be separated by at least one space. Numeric items may be either integer or decimal (see Note
below), string items must be enclosed in single quotes (‘).
Table V-2. Hot List File Record Format
Field #

Description

Format

1

Pulsar ID (B1950 or J2000)

String[12]

2

Right Ascension Hours

Numeric

3

Right Ascension Minutes

Numeric

4

Right Ascension Seconds

Numeric

5

Declination Degrees

Numeric

6

Declination Minutes

Numeric

7

Declination Seconds

Numeric

8

Comment

String[40]

Note: The numeric quantities for Right Ascension and Declination may be entered using any
combination of decimal and integer quantities, as long as all fields are present (use 0 for
unused fields). For example, a Right Ascension of 12h, 14m, 23.2s may be entered as “12 14
23.2”, “12 14.3867 0”, or “12.239778 0 0”.

V-2.3 Recorded Signal Data File
Recorded Signal Data files (normally given the extension .PLR - see Section IV-2) are created when recorded radio signals
from pulsars are saved. These files are later read in and analyzed using the facilities of the Data Analysis window. The
format of the file records is given in Table V-3. For decimal data items, the number in parenthesis is the number of digits to
the right of the decimal point. Data items in the records are separated by commas. (Although in Text format, these files
would not normally be edited off-line.) The number of data records in the file (beginning with record #5), is <= 1601.
(Table is located on the following page.)
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Table V-3. Recorded Signal Data File Record Format
Record

Field 1

Format

Field 2

Format

Field 3

Format

1

Pulsar ID (B1950 or
J2000)

String[12]

Telescope Aperture
(Meters)

Integer

Number of Slave
Receivers (0-2)

Integer

2

Rcvr 1 Frequency
(MHz)

Decimal(2)

Rcvr 2 Frequency
(MHz)

Decimal(2)

Rcvr 3 Frequency
(MHz)

Decimal(2)

3

Rcvr 1 Gain (0.125-8.0)

Decimal(3)

Rcvr 2 Gain (0.125-8.0)

Decimal(3)

Rcvr 3 Gain (0.125-8.0)

Decimal(3)

4

Start Time (Julian Day
minus 2,400,000)

Decimal(8)

Delta T between data
records (Seconds)

Decimal(8)

5

Rcvr 1 Signal at T0

Decimal(3)

Rcvr 2 Signal at T0

Decimal(3)

Rcvr 3 Signal at T0

Decimal(3)

6

Rcvr 1 Signal at T0 +
Delta T

Decimal(3)

Rcvr 2 Signal at T0 +
Delta T

Decimal(3)

Rcvr 3 Signal at T0 +
Delta T

Decimal(3)

etc…

V-3. Using a Spreadsheet Program
This software provides the following features to expedite students’ use of a spreadsheet program for data reduction and
analysis:
1.

Measurements made in the Data Analysis window may be saved in files (*.CSV) that are formatted for import
into most commercial spreadsheet programs.

2.

If an available spreadsheet program is identified in the Spreadsheet Program File field on the File Name
Options dialog (see Section V-1.3), the spreadsheet may be accessed directly from the exercise.

Selecting Results->Save Recorded Measurements from the Data Analysis menu causes recorded measurements to be
written to a file (qualifier .CSV) that is suitable for import into a spreadsheet program. In addition to recorded measurements,
records in this file also contain relevant information from the recorded signal data being measured. The format of the data
records in the .CSV file is given in Table V-4. For decimal and floating point data items, the number in parenthesis is the
number of digits to the right of the decimal point. Prior to the data records, the file contains records which include the date
and time, table number, login names, and column headers. Data items in the records are separated by commas, strings are
enclosed in single quotes (‘). See Table V-4 on the following page.
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Table V-4. Measurements File Record Format
Field

Data Type

Field

Data Type

Pulsar ID (B1950 or J2000)

String[12]

Data Start Time (Julian Date minus
2,400,000)

Decimal(8)

Receiver Frequency (MHz, 400.0-1400.0)

Decimal(2)

Comment (added when measurement
recorded)

String

Receiver Gain (Relative, 0.125-8.0)

Decimal(3)

Number of Data Records in Recorded Signal
Data

Integer

Reference Cursor Reading (Seconds)

Decimal(6)

Delta T from Recorded Signal Data
(Milliseconds)

Decimal(2)

Vertical Cursor Reading (Seconds)

Decimal(6)

Telescope Aperture (Meters)

Integer

Horizontal Cursor Reading (Relative - this
quantity has been factored by the receiver
gain)

Float(4)

Signal Data File Name

String

If the software finds an entry in the Spreadsheet Program File field on the File Name Options dialog (Section V-1.3), the
Spreadsheet item on the Results pop-up (Data Analysis menu) is enabled. Selecting Results->Spreadsheet will then start
the spreadsheet software. If a file of recorded measurements has been saved immediately prior to accessing the spreadsheet,
that file will be automatically loaded when the spreadsheet appears. If this is not the case, or to load another file, select File>Open from the spreadsheet menu. Be sure that the file type (.CSV) is specified. (This might be located under a generic
heading like “Text Files”.) Techniques differ depending on the spreadsheet used - consult your documentation. To return to
the exercise, either minimize the spreadsheet program or exit from it.

ASTRONOMICAL DATA, MODELS AND ALGORITHMS
VI-1. Pulsar Signals
The simulated signal displayed and recorded as a function of receiver frequency is a sum of three components: the pulse
signal as a function of time, the sky background as a function of sky effective temperature, and the instrument background as
a function of instrument effective temperature. Poisson noise is independently applied to each of these components before
they are combined. The generation of pulse data, including the determination of pulsar periods, the simulation of pulse
profiles and the effect of dispersion, is described in Section VI-1.1 below. Section VI-1.2 covers the determination of
background levels and noise, while Section VI-1.3 describes how the components are assembled to yield the signal strength
as a function of time and frequency.
VI-1.1. Pulse Data
In order to minimize the amount of calculation required at each time step (so that the display is generated at as close to a real
time rate as possible), the basic pulse data is pre-generated and placed in a table when the Mode button on the receiver is
pressed to switch the mode to “Receive”. (This also occurs when the telescope tracking is turned off and a new pulsar drifts
into the telescope field.) The generated table holds a maximum of 2000 points; the time interval between points is the same
as on the receiver display and is determined from the Horz. Secs parameter. (Since the receiver display has 400 points, the
generated pulse data is sufficient for nearly five full screens before wrapping is required. The maximum time interval
covered is 2.5 to 80 seconds, depending on the Horz. Secs setting.) The start time and rollover point of the data are adjusted
so that the initial and final phase is 0.5 (see Section VI-1.1.1). This guarantees that the data does not begin or end somewhere
within a pulse. Poisson noise (Section VI-1.2) is applied to this data when it is generated, but no sky or instrument background.
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Note: The generation of the pulse data table, combined with other initialization activities, may result in a
considerable delay on machines with 386 processors when the receiver Mode button is pressed or a pulsar drifts
into the field.
Unless otherwise defined, all parameters in the discussions that follow are found in Table V-1 (Section V-2.1).
VI-1.1.1. Pulsar Period and Phase
To find the current period of the pulsar, we compute the quantity DelP from DelP = DelT * PDot, where DelT is the current
Julian Date minus PEpoch, converted to seconds. Then, PCurrent = P + DelP.
To find the current phase, we compute the mean period from PMean = P + DelP/2. The phase is then the fractional part of
DelT/PMean. Since we want the initial phase to be 0.5, we compute DelPhase = 0.5 - Phase. The observation start time (see
Table V-3) is then set to the current Julian Date + DelPhase * PDays, where PDays is PCurrent converted to days. This
process assures that separate observations, made at time intervals of hours or even days, can be combined to determine
periods to high accuracy.
VI-1.1.2. Pulse Profiles
Pulse profiles are simulated by a Gaussian profile. The parameter W50 is used to set the standard deviation, while the
parameter s400 sets the pulse strength (various scale factors, some of them arbitrary, are applied). At each time step, the
phase change since the last step is determined and the integral of the Gaussian function over that range is evaluated (normalized
so that the total area under the curve is 1.0). The value of the integral is then multiplied by the pulse strength to obtain the
data point, which is stored in the pulse data table after applying noise (see Section VI-1.2). To speed the process, a table of
values for the Gaussian integral is generated initially by Simpson’s Rule. The integrals are then evaluated by interpolating
the tabular values.
If the time increment is greater than 0.3 period, the above process is not used. Instead, the number of pulses (including
fraction) since the last step is computed and multiplied by the pulse strength. This, of course, means that for the shortest
period pulsars, individual pulses will not be clearly delineated at longer time increments. (The time increment is determined
by dividing the value of the Horz. Secs parameter on the main receiver by 400). However, the smallest possible value of the
Horz. Secs parameter (0.5 seconds) is sufficient to accurately resolve pulses for all pulsars in the data file (Section V-2.1).
A number of pulsars exhibit a double-peaked pulse profile. This feature is not simulated by this software, since there is no
information in the pulsar data file (see Section V-2.1) on which to base such a simulation.
VI-1.1.3. Pulse Dispersion
The equation governing the delay between two frequencies f and f is
1

t 1 - t 2 = 4150 * DM * (1 f - 1 f
2
1

2
2

2

)

where t1 and t2 are expressed in seconds, and f1 and f2 in megahertz. The parameter DM is called the dispersion measure, its
units are parsecs/cm3 (see Table V-1). This delay is calculated and applied when displaying pulse data at other than the base
frequency of 400 MHz, as described in Section VI-1.3.
VI-1.2. Background and Noise
The background signal includes contributions from both the sky and the instrument (antenna, detector, etc.). The base level
for each component at the receiver frequency is obtained from Planck’s Law, using TBg (Table V-1) for the sky temperature
and the Detector Temperature parameter (Section V-1.1) for the instrument. A factor reflecting the size of the antenna (see
Antenna Aperture parameter - Section V-1.1) is calculated and applied to the instrument contribution. The Background
Base parameter (Section V-1.1) yields a factor that is applied to the sum of the background components.
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This parameter may be used to adjust the overall background level.
Poisson noise is applied to the background signal via function POIDEV(XM), which returns an integer value that is a
random deviate drawn from a Poisson distribution of mean XM (Press, et al, Ch. 7). This function is also used to “noise”
the pulsar signal (see Section VI-1.1.2).
VI-1.3. Generating the Signal
The following steps outline the process employed to generate each point of the displayed signal for each active receiver:
1.

If the receiver is operating at the base frequency (400 MHz), the next point is taken from the pulse data table
(Section VI-1.1). If the receiver is operating at a frequency other than the base frequency, the dispersion
(Section VI-1.1.3) is used to calculate a time offset, which in turn yields an offset in the index used to access
the table. The index is adjusted as needed to keep it within the bounds of the table (rollover/rollback).

2.

If the Beam Width parameter (Section V-1.1) is zero, an attenuation factor is computed from the offset of the
pulsar from the center of the beam. This computation employs the half-power beam width calculated from the
antenna aperture and frequency, and assumes an exponential drop-off in signal strength away from the beam
center. If the Beam Width parameter is non-zero, the signal is taken at full strength anywhere within the beam,
and zero outside of it.

3.

An antenna factor is computed from the square of the Antenna Aperture parameter. The antenna and attenuation
factors are applied to the value from Step 1.

4.

The pulsar flux at the receiver frequency is obtained by simple interpolation from the s400, s600, and s1400
values (see Table V-1). (Three-point interpolation was attempted, but abandoned when it was frequently
found to yield negative fluxes at intermediate frequencies.) A frequency factor is computed from the ratio of
this flux to the s400 value, and applied to the value from Step 3.

5.

The background signal (Section VI-1.2) is computed and added to the results of Step 4, yielding the total
signal.

VI-2. Pulsar Sound Effects
In order to enhance the realism of the simulation, and to reinforce in the students the idea that a pulsed signal is being
received, we have included sound effects in the exercise software. The sound feature is implemented through the WaveOut
family of Windows API functions, the general technique employed is presented in Section VI-2.1. In Section VI-2.2 we
describe our method of simulating the sound of actual pulsars. Certain characteristics of the WaveOut interface make it
difficult to maintain synchronization between the sound and video display under all circumstances, especially on slower
(486/386) machines. This issue is discussed in Section VI-2.3.
Generation of the pulsar sound effects requires the presence of a Sound Blaster compatible audio card (8-bit is sufficient)
and speakers. Unfortunately, we encountered technical difficulties that we have so far been unable to resolve in integrating
the sound features into the 16-bit version of the software. This capability is therefore available currently only in the 32-bit
version (for Windows 95/NT).
VI-2.1 General Technique
The Windows API facilities for producing sound require that sound buffers (or “pages”) be allocated, filled, and passed to
the sound system via function WaveOutWrite. Each buffer is played in its entirety and then passed back via a callback
routine for reuse or deallocation. Multiple buffers are necessary to assure uninterrupted sound.
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Specifics of the pulsar sound implementation in this software are as follows:
1.

Initially, six buffers are allocated. Three are used on a rotating basis for the pulsar sound, the remaining three
are employed as needed to introduce timing delays (see Item 4 below).

2.

To minimize memory (RAM) requirements, the sound buffers are sized as follows:

•

8-bit monaural sound (1 byte per sample) is employed. This was found by experiment to be
entirely adequate, and also minimizes requirements for the user’s sound card.

•

A sampling rate of 5512 Hz, giving a maximum sound frequency of 2756 Hz (by the Nyquist
criterion, the maximum sound frequency is ½ the sampling rate), was found to yield satisfactory
pulsar-like sounds (Section VI-2.2), as well as moderately sized buffers.

•

If the period of the pulsar is less than 0.5 seconds, then each pulsar sound buffer holds about two
seconds of sound (exactly Round(2/Period)*Period). Otherwise, each buffer holds one period
of sound. (See the discussion of buffer length in Section VI-2.3.)

3.

Pulsar sound buffers are generated from the pulse data table (Section VI-1), as described in Section VI-2.2
below.

4.

To minimize computational overhead and the risk of possible gaps in the sound or delays to concurrent processes
(primarily the video display), the sound buffers are (re)generated only in the following situations:

•

All three pulsar sound buffers are filled when the receiver is started. Under normal conditions
these buffers are simply “recycled” (i.e., immediately sent back to the sound system without
change) as they are returned.

•

All three pulsar sound buffers are flagged for regeneration when there is a 1% or greater change
in the signal attenuation (i.e., tracking is off and the pulsar is drifting into or out of the field).
Flagged buffers are regenerated one at a time, as they are played and returned by the sound
system.

•

All three pulsar sound buffers are similarly flagged for regeneration when there is a change in
the receiver frequency. In this case, appropriate timing delays are calculated from the dispersion
(Section VI-1.1.3) and introduced via extra buffers filled with noise only (see below) .

•

The three remaining buffers are held in a pool and used to introduce timing delays (see Section
VI-2.3). When needed, a buffer is selected, its data length is established by the required delay
time, and it is filled with noise only. When any of these buffers are returned from the sound
system, they are flagged as available and returned to the pool until needed. Allocating these
buffers initially and holding them until sound generation is finished avoids any overhead
associated with repeated memory allocation/deallocation.

VI-2.2 Simulating the Pulse Sound
The “sounds” made by pulsars, as recorded via radio telescopes, depend on several factors; one of the most important being
bandpass. We are fortunate to have in our possession, thanks to J.H. Taylor, recordings of pulsar sounds made by various
astronomers at Arecibo. Although we made no attempt to analyze these technically, they served as the basis for our simulation
in that we simply listened to them and then attempted experimentally to create a similar sound.
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The resulting technique for the generation of each sound sample point is as follows:
1.

Data corresponding to the correct phase is taken from the pulse data table (Section VI-1). Since the interval
between sound samples is much less than the table increment (1/5512, as compared to 1/25 to 1/800 second),
interpolation of the table values is required.

2.

Frequency (from the main receiver setting), antenna, and attenuation factors, as well as background noise, are
applied in a manner similar to that described in Section VI-1.3 for the video signal. Scaling is applied to yield
values in the range 0-255 for storage in 8 bits. (Occasional values above 255 are truncated.)

3.

If the sound buffer is filled with the values generated in Step 2, the resulting pulse sound is unsatisfactory; a
barely audible “whoosh”, unlike the distinct “chuff” heard on the pulsar recordings. However, it was discovered
that the simple technique of multiplying each point by function Random (which returns a random real number
in the range 0.0-1.0) before scaling yields a sound that is remarkably similar to the recordings.

If desired, the user can alter the effective bandpass of the generated sound by varying the sampling rate (see Sound Sample
Rate parameter in Section V-1.1). The main effect of this is that more and more high-frequency noise is added as the
sampling rate is increased. However, buffer requirements increase, the resulting sound begins to differ from the recorded
pulsars, and in addition, higher sampling rates may exacerbate synchronization problems by increasing computational overhead
(Section VI-2.3).
VI-2.3 Synchronizing Sound and Video
The pulsar sound effects are generated using the frequency setting from the main receiver to establish pulse strength, noise
level and dispersion delay, and are intended to synchronize with the main receiver video display. However, users may find
that after a time the video and sound get “out of sync”. In our experience this effect is rarely seen on machines with Pentium
processors, but is quite common on slower ones, even the faster 486 models. (We suspect that the overall performance of the
video card plays a significant role in this, perhaps more than the CPU.) Unfortunately, we have been unable so far to develop
a complete solution to this problem. We provide a means, as described in Section VI-2.3.2 below, of adjusting the overall
video display rate to synchronize with the sound. However, a major problem in addition to the overall rate is the fact that the
video display will sometimes not proceed smoothly but rather appear to undergo “hitches” or “fits and starts” that cause it to
fall behind the sound. These glitches appear more frequently when more than one receiver is active, and are undoubtedly
caused by momentary processing overloads on either the CPU or the video system.
Ideally, one would like the software to be self-correcting. That is, to establish some link between the sound and video
systems that would keep them synchronized or at least quickly restore synchronization if it is lost. Unfortunately, factors
which preclude this type of approach include the following:
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1.

The video display is generated point by point by the software. Thus the software is always in control of the
state of the display. The sound, on the other hand, must be pre-generated in buffers and sent to the sound
system, which is in complete control of playing it.

2.

The sound system operates independently and in real time, which it must to avoid gaps or distortions. The
video system is subject to waits and interruptions which may be generally insignificant to most applications,
but are sufficient to cause the loss of synchronization.

3.

There is little direct control of the sound, once a buffer has been sent. There is no direct command to start
playing, or (especially) “stop wherever you are and play the next buffer immediately”. (You cannot stop
playing in the middle of a buffer.)

4.

Since at any given time the sound system is holding two buffers (one playing and one waiting), and the buffers
average one to two seconds in length (making them significantly smaller is impractical for a number of reasons,
and is likely to create more problems than it would solve), any synchronization changes made through the
buffers will occur only after noticeable delays.
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The net result is that there is no direct method we are aware of to keep the video and sound “in step” at all times. On the other
hand, the “out of sync” condition is generally noticeable only with the longer period pulsars (greater than ~1/2 second), and
(as noted earlier) is not a significant problem on the newer Pentium PCs.
Additional information on sound/video synchronization is provided below as follows: The techniques used to introduce the
dispersion delay and other changes into the sound stream when the receiver frequency is changed are described in Section
VI-2.3.1, while Section VI-2.3.2 outlines a process by which the user can make some improvements to the synchronization
by altering the display rate.
VI-2.3.1 Synchronizing After Frequency Changes
If the frequency of the main receiver is changed while the receiver and pulsar sound effects are active, several changes
generally occur in the received signal that must be reflected in the sound. In particular, the pulse strength and background
noise level change, and the difference in the timing delay due to the dispersion effect at the old and new frequency results in
a phase shift in the received pulse. Since the video display is generated point by point, the effects associated with the
frequency change appear immediately. However, due to its buffered nature, the sound requires a few seconds to adjust. The
process is as follows (also see General Technique, Section VI-2.1):
1.

The three pulsar sound buffers are flagged for regeneration. As they are played and released they will be
refilled with sound data created at the new frequency.

2.

A delta t is computed from the difference between the dispersion delay at the old frequency and the dispersion
delay at the new. Since timing adjustments are made by adding extra time in the form of noise to the sound
stream, any resulting negative delta t is made positive by adding time in increments of one period.

3.

A delay buffer of length delta t is generated and sent to the sound system. This buffer contains noise only,
computed at the level appropriate to the new frequency.

The user will therefore generally observe the following on a frequency change:
1.

Although the video will change immediately, the sound may emit one or more additional pulses at the old
frequency.

2.

The noise level in the sound will then change to that of the new frequency. One or more pulses may go by
silently during this transition.

3.

Pulse sounds will restart synchronized with the video display. The receiver will not accept additional frequency
changes until this occurs.

VI-2.3.2 Adjusting the Display Rate
The Sound Sync Factor parameter (Section V-1.1) provides the user a means of improving the overall synchronization
between sound and video by altering the sound rate. The parameter actually represents the ratio of the generated sound rate
to the generated video rate. (The default, determined by experimentation and found to hold on several machines covering a
range of processor speeds, is 0.920. This implies that the video signal display normally runs at a rate slightly faster than real
time.) If you are having sound/video synchronization problems that seem to be due to a difference in the rates, you can make
adjustments to this parameter. (You should read Section VI-2.3 before making any changes. Complete synchronization may
not be possible.)
Note: a difference in the video and sound rates will manifest itself by the sound and video drifting in and
out of synchronization at a constant rate over time. Adjusting the Sound Sync Factor will not correct a
phase shift (a time difference between the sound and video pulses that remains nearly constant), although
stopping and restarting the receiver often will.
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To synchronize the sound and video rates:
1.

Start the software. You should have a minimum (ideally zero) of other programs open.

2.

Log on as “instructor” and enter the password to access the options.

3.

At this point you can enter your first guess for a new Sound Sync Factor (see Step 6) and press OK, or you
can simply press Cancel. A screen will appear asking if you want to retain access to the options. Select Yes.

4.

Select File->Run->Radio Telescope. Turn tracking on, then point the telescope at a strong pulsar with a
period of a second or more. (You can use the Hot List for this. Pulsar 0608-28 is a good choice.)

5.

Access the receiver and begin receiving. Note any phase difference between the sound and video. (You may
want to open additional receivers, if you will normally have more than one receiver active.)

6.

Close the receiver and select File->Preferences. Enter a new value for Sound Sync Factor. (If the sound
appeared in Step 5 to be running ahead of the video, enter a larger value (like 0.93) for the factor. In the
unlikely event that the sound is behind the video, decrease the value of the factor.) Make only small changes!
(As a data point, a 50 MHz 486DX machine that we use for testing operates best with a sound sync factor of
0.935.)

7.

Iterate Steps 5 & 6, making smaller and smaller changes until a satisfactory synchronization is achieved. Be
sure you save the last change to the options that you make. (You may also want to record it so you can set other
similar machines without the iteration process.)

It bears repeating that sound/video synchronization difficulties stem from a number of factors, as discussed in Section VI2.3. This adjustment affects only one of them. If you often experience an “out of sync” condition and wish to minimize the
possibility while still retaining the sound effects (for example, during a demonstration), take note of the following:

•

Avoid changing frequencies when the receivers are active, expecially if more than one receiver is open. Set all
receivers to desired frequencies before pressing the Mode button to begin receiving.

•

Do not operate receivers with the telescope tracking turned off. This situation creates the greatest processing
overhead because the sound buffers must be continually regenerated as the signal attenuation changes.
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